error in php 5.4.5

Ask Questions or make comments about Mp3 Toolbox
Post Reply
pdance
Posts: 1
Joined: Mon Aug 06, 2012 7:54 pm

error in php 5.4.5

Post by pdance » Fri Aug 10, 2012 6:03 pm

php function eregi () was removed from the php version 5.3

what's the solution?

User avatar
Jay
Will work for food (Administrator)
Posts: 2830
Joined: Mon Jan 14, 2002 12:48 am
Location: Next Door
Contact:

Re: error in php 5.4.5

Post by Jay » Tue Aug 14, 2012 1:36 am

you can disable deprecation errors, i will patch mp3 toolbox for this change.
- Jay

dismuke
Posts: 6
Joined: Tue Sep 30, 2008 11:35 am

Re: error in php 5.4.5

Post by dismuke » Sat May 21, 2016 1:43 pm

I am getting this error on an old site that is no longer active but still archived and public. How does on disable deprecation errors? Is the patch included in the download that is now available on the site? If so, is there a way I can install it on top of my present installation so that everything in terms of content and links does not have to be recreated from scratch?

dismuke
Posts: 6
Joined: Tue Sep 30, 2008 11:35 am

Re: error in php 5.4.5

Post by dismuke » Sat May 21, 2016 2:09 pm

In addition to the deprecation error I am also getting additional errors that I assume might have something to do with the php upgrade as at one time everything worked perfectly and no changes at all have been to the site or the mp3 Toolbox installation since that time:

These occur when clicking on an mp3 Toolbox generated audio link:

Warning: Cannot modify header information - headers already sent by (output started at /homepages/1/d88146527/htdocs/dismuke/how_content/index.php:70) in /homepages/1/d88146527/htdocs/dismuke/how_content/index.php on line 667
Warning: Cannot modify header information - headers already sent by (output started at /homepages/1/d88146527/htdocs/dismuke/how_content/index.php:70) in /homepages/1/d88146527/htdocs/dismuke/how_content/index.php on line 668

dismuke
Posts: 6
Joined: Tue Sep 30, 2008 11:35 am

Re: error in php 5.4.5

Post by dismuke » Sat May 21, 2016 2:32 pm

My web hosting service had an option where I was able to revert my php back to 5.2 which they indicated was under "extended support" for them. Everything works fine now. But my guess is it is only a matter of time before they will stop supporting it. So any assistance would be very appreciated. mp3 Toolbox is a wonderful program that I very much valued when I was operating that old site - and is something that I was hoping to be able to use on a future site that is in planning.

User avatar
Jay
Will work for food (Administrator)
Posts: 2830
Joined: Mon Jan 14, 2002 12:48 am
Location: Next Door
Contact:

Re: error in php 5.4.5

Post by Jay » Sun May 22, 2016 5:13 am

Ok, I will see about making a PHP 6 friendly version. I am honestly considering overhauling the interface to take advantage of some stuff we are doing in Steamcast anyway so maybe a rewrite is in order..
- Jay

Post Reply