Steamcast sending VPS CPU to 100%

Steamcast is a stand alone server that combines the features of SHOUTcast and Icecast2 and more to make one mega awesome server.
Post Reply
stationx
Posts: 24
Joined: Sun Dec 28, 2008 9:26 am

Steamcast sending VPS CPU to 100%

Post by stationx » Sun Jun 16, 2019 9:30 am

Hi guys,
Been running the Decennium 102 version of steamcast on windows server 2012 for a while now. Works great for ages then every so many weeks it will send the CPU to 100% and the vps sends me alarm emails. The fix has been to just reboot the vps as it boots so fast you hardly notice a glitch. But as you can imagine this is getting a little sad....

I'm not sure what is causing the problem.... But I notice it doesn't happen on "real pc's" with the exact some version of steamcast on them. I run a pc at the studio with a copy of steamcast on it and the public VPS relays from it. I do it this way to combat internet jitters better and so i can listen locally without incurring a download from the outside world. The local version never fails..... The public one every 3/4 weeks this problem happens.

I'm not sure what is triggering the issue. But the public VPS does have 2 steamcast servers installed. The first steamcast is on the standard 8000 port and then the second steamcast listens to the port 8000 server internally as local host.This is how I look after my port 80 listeners. Both can be streamed publicly.... This is my way of utilising the port 80 that comes with my vps ip. It's always the port 80 server that sends the vps CPU to 100% never the port 8000 server....

I've often wondered if it's because port 80 is for surfing the web that there is a lot of " invalid source requests" upsetting the server? Any suggestions greatly appreciated....

thanks heaps

stationx
Posts: 24
Joined: Sun Dec 28, 2008 9:26 am

Re: Steamcast sending VPS CPU to 100%

Post by stationx » Fri Sep 20, 2019 6:54 pm

Hi guys,

I seemed to have worked out my issue myself. Steamcast keeps listening on the port +1 even if you are using it in relay mode for everything. Why people are only now trying to stream using my server is a mystery. This wasnt an issue for years before.

When attempting to connect my server rejects them and it does something that sends the cpu on the vps to 100%. I'm not sure why or if it is part of something more malicous or just a bug with steamcast.

I've found the fix for me is to block the listening port -- if you are on 8000 I block port 8001.... If you are on a VPS host that doesnt give you a firewall in your deal then you need to look over windows firewall. This is where you find out that at setup windows firewall opens ALL PORTS to stemacast. Dropping this back to "inbound rules" and setting it to port 8000 you will have fixed it. Problem now is you cant come in on port 8001 if you are pushing.

Fortunately for me the host closer to home does offer a decent firewall and i can get more trick with it. This is where a static IP helps.... I can open port 8001 only for that person's IP.
I tried setting the SrcIP to 127.0.0.1 but it didnt work -- did i mess up? Would this be a bugg? It should have limited the server to only local source requests. It wouldnt have fixed the problem here closer to home... it needs to do both.

cheers all

User avatar
Max
Posts: 125
Joined: Fri Oct 21, 2011 1:39 am

Re: Steamcast sending VPS CPU to 100%

Post by Max » Wed Oct 16, 2019 1:40 pm

The +1 I believe is due to legacy support for Shoutcast V1 DSP plugin for Winamp. Shoutcast V1 would listening to +1 for the source encoder.

Eating up the CPU is a bug tho.

stationx
Posts: 24
Joined: Sun Dec 28, 2008 9:26 am

Re: Steamcast sending VPS CPU to 100%

Post by stationx » Fri Oct 18, 2019 6:57 pm

Thanks Max

Is there a way to stop steamcast from listening for incoming sources while used in relay mode? I've tried setting the SrcIP in the config to 127.0.0.1 so it only accepts local sources. But it doesn't work.

Most of the time I can stop this problem with firewall settings at the VPS provider. By blocking the +1 port. But I still see the odd one slipping through. I'm not sure if there is something they are doing that confuses the firewall and lets it through.

I use steamcast in relay mode for all public servers, I don't need steamcast listening for sources pushed to it.... a work around that simply turns this off would make my day!

Regards & Cheers

Peter

Post Reply