Steamcast Admin Panel cuts off...

Steamcast is a stand alone server that combines the features of SHOUTcast and Icecast2 and more to make one mega awesome server.
Post Reply
altimit
Posts: 7
Joined: Fri Jan 06, 2006 4:43 pm
Location: AR, USA
Contact:

Steamcast Admin Panel cuts off...

Post by altimit »

I really didn't know how to search the forum for this although I tried and failed.. Basically.. anything after 10 clients being listed completely destroys the rest of the admin panel. HTML code does not finish generating and the server closes the connection as if the page was sent successfully.

This happens in both IE and Firefox.
See below my screenshot from Firefox.

the image was not modified in any way except to blur out listener/server IP addresses for privacy and security reasons.

http://radio.animeacademyradio.net/steamcast_admin.png

Here is a snip from the HTML source to show that its cutting off:

Code: Select all

<tr><td bgcolor="#003333">IPADDR</td><td class=servcell>/ (/aar.mp3)</td><td class=servce
Any suggestions?
Server info:
Linux haibane.zefie.com 2.6.11.10-xenU #2 Fri Aug 5 00:07:41 EDT 2005 i686 i686 i386 GNU/Linux

I just wish I could get past this little problem because I find SteamCAST 200% better than the original DNAS and will propose that our entire station migrate over to SteamCAST if we can defeat this little glitch ^.^

User avatar
Jay
Will work for food (Administrator)
Posts: 2919
Joined: Mon Jan 14, 2002 12:48 am
Location: Next Door
Contact:

Post by Jay »

yea that seems to be aflicting some Linux flavored OS's I have not ran across a server of my own that does it. Likely steamcast is just closing off the connection before it finishes outputing the HTML because the OS is flagging the connection which steamcast is just not handling correctly. I'll try to introduce some debugging code for this problem in the next version.
- Jay

altimit
Posts: 7
Joined: Fri Jan 06, 2006 4:43 pm
Location: AR, USA
Contact:

Post by altimit »

Jay wrote:yea that seems to be aflicting some Linux flavored OS's I have not ran across a server of my own that does it. Likely steamcast is just closing off the connection before it finishes outputing the HTML because the OS is flagging the connection which steamcast is just not handling correctly. I'll try to introduce some debugging code for this problem in the next version.
Thanks for the fast reply. If it would help you, I can give you a shell account on my server so you can debug it easier. ^.^

Edit: Another note.. I added some sources, one of which will rarely be used, and it seems to not do it anymore? Or maybe because I haven't hit a high enough listener count (40 in first screenshot, 20 in this one) for it to happen? I don't know, but figured it was worth posting..

http://radio.animeacademyradio.net/steamcast_admin2.png

Post Reply