Problems With Steamcast

Steamcast is a stand alone server that combines the features of SHOUTcast and Icecast2 and more to make one mega awesome server.

Are you having problems with Steamcast?

Yes
5
63%
No
3
38%
 
Total votes: 8

User avatar
Jay
Will work for food (Administrator)
Posts: 2865
Joined: Mon Jan 14, 2002 12:48 am
Location: Next Door
Contact:

Post by Jay » Sat Sep 09, 2006 4:49 am

have you tried the linux version of 0.9.73?
- Jay

DJ-Zath
Posts: 16
Joined: Mon May 09, 2005 3:29 am
Location: US - western Illinois
Contact:

Post by DJ-Zath » Sun Sep 10, 2006 11:08 pm

I haven't tried the Linux version of "973"..

(I figured that since I didn't have the compat or Linux libs.. that it wouldn't work..

just for S&G's, I'll download and try it tonight... (after this post)

Also, I have found a "bug" in 973 (that I'm sure you're aware of) being that when using "973" in relay mode, the "data timout" feature is whats dropping the streams when a "burp" comes along.. once the mount is driopped, it cannot recover- and even if the source logs back in, it will "core" after the "timeout" period is exceeded.

For this I recommend a feature to DISABLE "no data timeout", or, at least remove it from "relaying" mounts.

(I have VERY recently been experimenting with the different versions of Steamcast and different configurations which spawned from this very post.. I would like to discuss with you some of my findings.. I have since learned whats been causing the CPU overload.. but I'd rather tell you "in person" since I don't want to reveal this "exploit" to everyone lest it be used on someone else!

WARP has been "under attack" lets say.. and I have been trying to find ways to "harden" Steamcast from what I found to be "unnessessary but deadly" to Steamcast servers.

You know where to find me! :-)

-DjZ-
:) :)

DJ-Zath
Posts: 16
Joined: Mon May 09, 2005 3:29 am
Location: US - western Illinois
Contact:

Post by DJ-Zath » Mon Sep 11, 2006 12:16 am

Heres what the Linux version does:
-----------------------------------------------------------------------------
Event Log:
[09/11/[email protected]:01:04] WARNING: ShowLastSongs not set between 1 and 50, assuming default
[09/11/[email protected]:01:04] Configuration loaded from Cast.cfg
[09/11/[email protected]:01:04] WARNING: steamcast.vip could not be loaded, no vips will be loaded
[09/11/[email protected]:01:04] WARNING: steamcast.ban could not be loaded, no bans will be loaded
[09/11/[email protected]:01:04] Error Initializing Client Port, unable to bind to 161.58.211.128:8000
[09/11/[email protected]:01:04] Listening to ANY:8001 for incoming source connections...
[09/11/[email protected]:01:04] Source Thread Shutting Down
[09/11/[email protected]:01:04] Listening to 8000 for incoming stat connections...
[09/11/[email protected]:01:04] PID: 6503
[09/11/[email protected]:01:04] Relay thread created #0
[09/11/[email protected]:01:04] Relay Thread Ended for Source #0
[09/11/[email protected]:01:04] Server Shutdown complete.
----------------------------------------------------------------------------

Since I do *NOT* have root prevliges, I CANNOT bind to "localhost".

I have been assigned a "virtual IP" in which I have to use, however, this version won't bind to the assigned IP- even though I have:

ServIP=161.58.211.128
SrcIP=ANY

(even if I was able to bind to "localhost".. how would YP see this?

it COULDN'T!)


Either way, the Linux version didn't work..

UPDATE:

I decided to try:

ServIP=ANY

and heres the resault:

Event Log:
[09/11/[email protected]:22:07] WARNING: ShowLastSongs not set between 1 and 50, assuming default
[09/11/[email protected]:22:07] Configuration loaded from Cast.cfg
[09/11/[email protected]:22:07] WARNING: steamcast.vip could not be loaded, no vips will be loaded
[09/11/[email protected]:22:07] WARNING: steamcast.ban could not be loaded, no bans will be loaded
[09/11/[email protected]:22:07] Error Initializing Client Port, unable to bind to ANY:8000
[09/11/[email protected]:22:07] Listening to ANY:8001 for incoming source connections...
[09/11/[email protected]:22:07] Listening to 8000 for incoming stat connections...
[09/11/[email protected]:22:07] PID: 7717
[09/11/[email protected]:22:07] Relay thread created #0
[09/11/[email protected]:22:07] Source Thread Shutting Down
[09/11/[email protected]:22:07] Relay Thread Ended for Source #0
[09/11/[email protected]:22:17] Server Shutdown complete.

-DjZ-
:) :)

Post Reply