Segmentation Fault...

Steamcast is a stand alone server that combines the features of SHOUTcast and Icecast2 and more to make one mega awesome server.
Post Reply
IDGT
Posts: 13
Joined: Fri Apr 28, 2006 10:40 am

Segmentation Fault...

Post by IDGT » Fri Apr 28, 2006 11:35 am

I'm running the Beta 0-9-73 on Linux RedHat 9 with three mountpoints. Here is my config...

PortBase=8000
MaxUser=10
;MaxBandwidth=0
;IPMaxUser=0
LogFile=streamcast.log
ScreenLog=Yes
RealtimeLog=Yes
YPLog=Yes
PidFile=steamcast.pid
NameLookups=No
ShowLastSongs=5
ClientTimeout=30

AdminUser=xxx
AdminPass=xxx

SourceMount=/idgt.mp3
;SourceBackup=
SourceUser=xxx
SourcePass=xxx
SourceUserMax=10
;SourceRelay=
;SourceAvgBitrateLimit=
SourceIsSC=Yes
;SourceNameFormat=%s powered by Steamcast
SourceIsDefault=No
;SourceIP=
;SourceAuth=No
;SourceAuthMax=0
;SourceListenerTimer=0
SourcePublic=Never
SourcePublicRelay=Yes
;SourceRawKey=rawdata (for Flash - http://localhost:8000/mount?rawdata
;SourceBuffUtil=100

SourceMount=/idgt.aac
;SourceBackup=/idgt.mp3
SourceUser=xxx
SourcePass=xxx
SourceUserMax=10
SourceIsSC=Yes
SourceIsDefault=No
SourcePublic=Never
SourcePublicRelay=Yes

SourceMount=/flash32
;SourceBackup=/idgt.mp3
SourceUser=xxx
SourcePass=xxx
SourceUserMax=10
SourceIsSc=Yes
SourceIsDefault=No
SourcePublic=Never
SourcePublicRelay=Yes

The system will run for about two minutes - with one listener (connected to the /idgt.aac - then die with a message as follows...

Segmentation fault3 Nodes: 1 (Unique: 1) Tx: 111.39 Kbps<->131.08 Kbps

It seems if I DO NOT send the artist title to the server - then everything runs OK - however, as soon as I start sending artist title - I get the above fault.

Still testing - but want to know if this is a known issue and how to get around it.

User avatar
Jay
Will work for food (Administrator)
Posts: 2867
Joined: Mon Jan 14, 2002 12:48 am
Location: Next Door
Contact:

Post by Jay » Mon May 01, 2006 2:42 am

nope, not known, what title is sent at the time of the crash?
- Jay

IDGT
Posts: 13
Joined: Fri Apr 28, 2006 10:40 am

Post by IDGT » Mon May 01, 2006 2:11 pm

OK - been testing this weekend, the sending of artist/title simply causes the segmentation fault to happen quicker/sooner. However, I get the segmentation fault regardless. Any suggestions?

User avatar
Jay
Will work for food (Administrator)
Posts: 2867
Joined: Mon Jan 14, 2002 12:48 am
Location: Next Door
Contact:

Post by Jay » Mon May 01, 2006 2:47 pm

try setting showlastsongs to 1
- Jay

IDGT
Posts: 13
Joined: Fri Apr 28, 2006 10:40 am

Post by IDGT » Tue May 09, 2006 3:36 pm

Haven't tried it yet - I have made the change to the config and will run tests over the next day or two and advise. Thanks for the tip.

IDGT
Posts: 13
Joined: Fri Apr 28, 2006 10:40 am

Post by IDGT » Mon May 15, 2006 12:59 pm

Haven't really been able to test - working on fixing another issue. I will update once we get the other issue resolved.

IDGT
Posts: 13
Joined: Fri Apr 28, 2006 10:40 am

Post by IDGT » Fri Jun 16, 2006 7:53 pm

OK - the segmentation fault is definitely when you send artist title to the server via http/url. If I do not send artist title, the server will run and no problems for over 15 hours. As soon as I attempt to send the artist title - the server crashes.

Anyone have a work around or a fix or a reason for this?

Lane
Posts: 152
Joined: Mon May 09, 2005 4:16 pm

Post by Lane » Fri Jun 30, 2006 11:29 am

Try running it as root user. I had some issues with non root. I never fully explored it, but i thought I'd make that suggestion.

Post Reply