On demand audio or video only facilitates one user at a time

Steamcast is a stand alone server that combines the features of SHOUTcast and Icecast2 and more to make one mega awesome server.
Post Reply
aberam
Posts: 3
Joined: Thu Dec 14, 2006 12:35 pm

On demand audio or video only facilitates one user at a time

Post by aberam »

Hi Jay,

I know that ondemand is beta, but just to let you know that it's allowing only one user at a time even though your max listeners are much higher. (Happens for both audio and video). When the first user connects it's fine but a second user connects you'll see it connect but it'll send about 200bytes and then hangs on that user and you see buffering 0% on winamp and it stays like that, however if the first user disconnects within a few seconds of the second request, the second user grabs the connection and works and the first user is now out of service. My reason for really wanting this to work is that streaming nsv from a webserver don't give you the option of fastforwarding or rewinding when watching but steamcast gives you that flexiblity. Thanks for your time and congrats on a really great server. (Dumped Shoutcast for hardly any features and can't do NSV ondemand and Icecast because it's to vague to use and uses a lot more resources than Steamcast). Happy Holidays and a Bright and Prosperous New Year.

Abe

User avatar
Jay
Will work for food (Administrator)
Posts: 2932
Joined: Mon Jan 14, 2002 12:48 am
Location: Next Door
Contact:

Post by Jay »

thanks, I will put it in my bugs list to check before next release. I plan on polishing on-demand abit as well it needs it.
- Jay

aberam
Posts: 3
Joined: Thu Dec 14, 2006 12:35 pm

Post by aberam »

Great, and thanks for the quick reply. Anticipating the fix and the new release with great anxiety.

Abe

aberam
Posts: 3
Joined: Thu Dec 14, 2006 12:35 pm

Ondemand only facilitates one user at a time

Post by aberam »

I re-installed 0.9.75 since I got an email notification that the bug was fixed however I'm still having the problem after reinstalling steamcast, the first user connects fine and plays the file but the second user connects and is stuck at 0% buffering and when you check the server status you see onlt 119b sent to the second client and it's stuck there, however if the first user disconnects soon after the second user tries to connect the second user grabs the connection and the first user is out in the cold. Thanks for taking the time to solve this problem.
Aberam

User avatar
Jay
Will work for food (Administrator)
Posts: 2932
Joined: Mon Jan 14, 2002 12:48 am
Location: Next Door
Contact:

Post by Jay »

would you mind posting the url to your server or pming it to me. Also post your config file with passwords masked.
- Jay

Post Reply