steamcast crashes (Assertion Failed C++ Error)

Steamcast is a stand alone server that combines the features of SHOUTcast and Icecast2 and more to make one mega awesome server.
Post Reply
2kj
Posts: 11
Joined: Tue Feb 19, 2008 5:04 am

steamcast crashes (Assertion Failed C++ Error)

Post by 2kj » Tue Feb 19, 2008 5:33 am

Hi,

im having this Assertion failed like once a week.
Running steamcast 0.9.7.5 Winamp 5.5.2 (newest) and Spacial Audio Encoders 3.7.5 (i think, it's the latest)

any help would be very appreciated

getting these Errors (they appear in this order if you click "ignore" on each box):

Image
Image
Image
Image
Image
Image
Image



Image
Image
Image
Image
Image
Image

Now one of the 2 Servers should work, the second apparently died
Last edited by 2kj on Tue Feb 19, 2008 6:49 pm, edited 1 time in total.

User avatar
Jay
Will work for food (Administrator)
Posts: 2862
Joined: Mon Jan 14, 2002 12:48 am
Location: Next Door
Contact:

Post by Jay » Tue Feb 19, 2008 4:00 pm

Your images are not loading for me.
- Jay

2kj
Posts: 11
Joined: Tue Feb 19, 2008 5:04 am

Post by 2kj » Wed Feb 20, 2008 6:04 am

fixed :)

User avatar
Jay
Will work for food (Administrator)
Posts: 2862
Joined: Mon Jan 14, 2002 12:48 am
Location: Next Door
Contact:

Post by Jay » Wed Feb 20, 2008 8:29 am

Those message box's are not referencing steamcast at all. Are you certain it is steamcast or something upstream?
- Jay

2kj
Posts: 11
Joined: Tue Feb 19, 2008 5:04 am

Post by 2kj » Wed Feb 20, 2008 9:42 am

you think it's another tool?

mostly then SAM Encoder or the Oddsock Transcoder, right?!

User avatar
Jay
Will work for food (Administrator)
Posts: 2862
Joined: Mon Jan 14, 2002 12:48 am
Location: Next Door
Contact:

Post by Jay » Wed Feb 20, 2008 5:24 pm

i am not familiar with their assertions so I don't know, perhaps you could give me a sequence of how the failure occurs, what happens when and then next and so forth to ensure that steamcast isn't the problem or contributing.
- Jay

2kj
Posts: 11
Joined: Tue Feb 19, 2008 5:04 am

Post by 2kj » Wed Feb 20, 2008 9:07 pm

when the error occurs no sound is streamed, so maybe it is a problem in winamp ..

we are streaming sets (selfrecorded by djs)
so may it be possible that the mp3s are corrupt at some point?

is there another solution than using the spacial encoders to connect to steamcast ?

the sets are in different quality so we need a transcoder between (i guess) and spacial did that exactly..

User avatar
Jay
Will work for food (Administrator)
Posts: 2862
Joined: Mon Jan 14, 2002 12:48 am
Location: Next Door
Contact:

Post by Jay » Thu Feb 21, 2008 4:21 am

you can try oddsock's encoder or the shoutcast encoder.
- Jay

Post Reply