Invalid login on source channel

Steamcast is a stand alone server that combines the features of SHOUTcast and Icecast2 and more to make one mega awesome server.
Post Reply
marowitch
Posts: 1
Joined: Wed Jun 30, 2010 1:47 pm

Invalid login on source channel

Post by marowitch » Wed Jun 30, 2010 1:58 pm

When i try to connect my winamp to steamcast server i get the message on server side:
Invalid login on source channel GET ?admin/metadata?pass=*****&mode=updinfo&mount=/live.mp3&song=song.mp3 HTTP/1.0;
Whats gona wrong?

User avatar
Jay
Will work for food (Administrator)
Posts: 2862
Joined: Mon Jan 14, 2002 12:48 am
Location: Next Door
Contact:

Re: Invalid login on source channel

Post by Jay » Thu Jul 08, 2010 5:08 pm

you need to connect to the destination port not the source port if you are trying to tune into the stream.
- Jay

Arkangel
Posts: 2
Joined: Sat Sep 25, 2010 3:25 pm

Re: Invalid login on source channel

Post by Arkangel » Sat Sep 25, 2010 3:40 pm

Jay -

Been trying to replace my IceCast with steamcast and i cant seem to get it. Steamcast always gives me the invalid login error. I have it set for clients to connect to port 80 and my server to accept connections on port 81. I set 81 in edcast standalone, and it just keeps kickin it back with bad login. Is there some setting i'm forgetting to set correctly?

See below for the log, and see attached for the conf file.

Event Log:
<09/25/[email protected]:33:28> [serv] Configuration loaded from N:\Program Files\Steamcas
t\steamcast.conf
<09/25/[email protected]:33:28> [serv] Mime types file loaded
<09/25/[email protected]:33:28> [serv] WARNING: steamcast.vip could not be loaded, no vips
will be loaded
<09/25/[email protected]:33:28> [serv] WARNING: steamcast.ban could not be loaded, no bans
will be loaded
<09/25/[email protected]:33:28> [serv] PID: 2736
<09/25/[email protected]:33:28> [serv] Listening to ANY:81 for incoming source connections
...
<09/25/[email protected]:33:29> [serv] Listening to 80 for incoming stat connections...
<09/25/[email protected]:33:29> [serv] Listening to ANY:80 for incoming client connections
...
<09/25/[email protected]:33:29> [serv] Starting Thread pool of 5 threads...
<09/25/[email protected]:34:34> [src] Source attempting connection from 127.0.0.1.
<09/25/[email protected]:34:34> [src] Source attempting connection from 127.0.0.1.
<09/25/[email protected]:34:34> [src] Invalid login on source channel SOURCE stream.mp3 IC
E/1.0;
<09/25/[email protected]:34:34> [src] Connection Closed
<09/25/[email protected]:34:34> [src] Invalid login on source channel GET /admin/metadata?
pass=******&mode=updinfo&mount=stream.mp3&song= HTTP/1.0;
<09/25/[email protected]:34:34> [src] Connection Closed
<Status> Sources: 0 Nodes: 0 (Unique: 0) Tx: 0.00 bps<->0.00 bps

Also, how you been? Haven't seen hardly anyone in IRC in months. We should try and have some sort of reunion or meet, either online or off, just for fun.
Attachments
steamcast_public.conf.zip
(5.42 KiB) Downloaded 111 times

User avatar
Jay
Will work for food (Administrator)
Posts: 2862
Joined: Mon Jan 14, 2002 12:48 am
Location: Next Door
Contact:

Re: Invalid login on source channel

Post by Jay » Mon Sep 27, 2010 6:54 am

If you are going to source connect on 81 with steamcast then you need to configure your encoder for SHOUTcast.
- Jay

Arkangel
Posts: 2
Joined: Sat Sep 25, 2010 3:25 pm

Re: Invalid login on source channel

Post by Arkangel » Mon Sep 27, 2010 9:46 am

So the issue was that when you go with the Shoutcast mode, you have to set your encoder to connect on the same port as the clients do, as opposed to the "source port". This makes no sense to me, but when i tried it, it worked. Pardon the noob. Thanks again.

User avatar
Jay
Will work for food (Administrator)
Posts: 2862
Joined: Mon Jan 14, 2002 12:48 am
Location: Next Door
Contact:

Re: Invalid login on source channel

Post by Jay » Mon Sep 27, 2010 10:07 am

correct, it's a shoutcast thing.
- Jay

Post Reply