Windows 10

Steamcast is a stand alone server that combines the features of SHOUTcast and Icecast2 and more to make one mega awesome server.
Post Reply
stationx
Posts: 21
Joined: Sun Dec 28, 2008 9:26 am

Windows 10

Post by stationx » Thu Feb 15, 2018 2:59 am

Hi guys,

I'm having trouble when Steamcast is installed on Windows 10 Home. Everything installs ok and if you use default passwords etc it works fine. I get into serious trouble when I setup users for an encoder to push to. To make this interesting somethings will change in the config and some will not. I'm guessing there might be some "administrator rights" or some read only properties that i need to change in windows 10 itself. It really looks like the web interface is blocked.... but not for everything thats the weird part....

Any ideas of what to look for?

regards

Peter

User avatar
Max
Posts: 110
Joined: Fri Oct 21, 2011 1:39 am

Re: Windows 10

Post by Max » Thu Feb 15, 2018 7:30 am

There is user roles that have to be added to the encoder to the mount its trying to stream to. Either that or you could set the encoder to be able to push to the entire server.

Steamcast shouldn't need administrator privileges on Windows 10. I currently test Steamcast on a Windows Server 2016 and use Windows 10 Pro at home for testing.

Can you provide some screenshots of the the problems you are seeing and PM me them?

stationx
Posts: 21
Joined: Sun Dec 28, 2008 9:26 am

Re: Windows 10

Post by stationx » Sat Feb 17, 2018 10:59 pm

thanks max
i thought i was setting the roles
i am using the same password that might be it... all i need to know for now is it does work on win 10 pro or home
thank you

stationx
Posts: 21
Joined: Sun Dec 28, 2008 9:26 am

Re: Windows 10

Post by stationx » Sat Feb 24, 2018 11:16 pm

yep silly me -- thanks max -- using the same password for all encoders --didnt like it

Post Reply