"Audio stream sounds distorted" problem.

Talk about Audio On Demand or Streaming
Post Reply
Ack
Posts: 1
Joined: Sat Mar 26, 2011 7:14 am

"Audio stream sounds distorted" problem.

Post by Ack » Sat Mar 26, 2011 8:18 am

My infinite apologies if this post does not fit either in this particular forum or on Radio Toolbox. If such is the case, any suggestions as to where on the internet I can address this question would be appreciated!

I am a broadcaster who does a live show through a remote server.

Every so often, the audio will develop distortion - a warbly sound kind of like an echo - in the stream to all the listening clients including the monitoring client that I run on a separate PC during the show. I sample the audio on that that client application when the microphone is off to avoid a feedback loop. (Yes, there is latency - but I thought I would mention that anyway... :D )

This problem has occurred using both Standalone Shoutcast and Standalone Edcast 3 encoders - both of which were running on a dedicated PC separate from the PC/Mixer combination that generates the analog audio sent to the encoder. Edcast 3 is the current encoder.

The occurance rate for this warbling problem is less than 10 percent and generally occurs after a stream is started. The last time this occured, I stopped the stream, then restarted it with no positive effect.

Important/Useless data:

128k MP3 bitrate
PC-based studio
Win7 encoder PC (multi-core AMD processor - no other apps running)
Audio source PCs are XP
"Sounds good going into the encoder PC" :D
broadcasting to/through a dyndns.org connection at the server end.
AT&T DSL connection. The connection is fiber - except for the last 2000 feet (+/-600m) of new thelephone infrastructure and is not shared except within the small LAN inside my home.
The upload stream occurs at 4:00pm CST and lasts for 2 hours
The server is located in the UK with a 6 hour time offset resulting in a UK-local broadcast time of 11:00PM.

What steps can I take to isolate the cause of this problem?
Could it be possibly caused by an occasional lack of bandwidth at my end?

Cordially,

Ack

User avatar
Jay
Will work for food (Administrator)
Posts: 2867
Joined: Mon Jan 14, 2002 12:48 am
Location: Next Door
Contact:

Re: "Audio stream sounds distorted" problem.

Post by Jay » Sat May 21, 2011 2:50 am

Are you certain the drivers for your audio card are up to date? Try running from a source other than the audio card to see if it disappears.
- Jay

broadcastcat
Posts: 4
Joined: Tue Aug 02, 2011 2:52 pm

Re: "Audio stream sounds distorted" problem.

Post by broadcastcat » Mon Sep 05, 2011 8:14 pm

It sounds like it is for sure a driver issue, the easiest way to figure this out is to switch back to the default sound mapper a few times and note the differences. Also you can run some repair tools like an inbox repair tool. You would be surprised at how common files can disrupt media codecs, etc.

Post Reply