Authentication problem

Steamcast is a stand alone server that combines the features of SHOUTcast and Icecast2 and more to make one mega awesome server.
Post Reply
nserver1
Posts: 2
Joined: Mon Jun 27, 2016 1:35 am

Authentication problem

Post by nserver1 »

Hi

I have a mount that I can stream from.

Without Auth enabled
url: http://192.168.0.4:8000/live
Stream displays on Home page

When Auth is enabled and I try to access, I get the following
Snap3.jpg
(22.31 KiB) Not downloaded yet
Stream no longer appears on home page
Snap2.jpg
Snap2.jpg (9.45 KiB) Viewed 11178 times
Try to access with default path
url: http://192.168.0.4:8000/live
see
Snap1.jpg
(14.75 KiB) Not downloaded yet
when I try access with username and password in the path with Firefox, it says that the website does not require authentication
url: http://user:[email protected]:8000/live

Config file contains the following:
SourceMount1=/live
SourceIsDefault1=Yes
SourceAuth1=Yes
SourcePublic1=Default

The user that I'm testing is created as "Listener" and have been added to the Stream

Please let me know if you require any further information
Any assistance would be appreciated

User avatar
Max
Posts: 141
Joined: Fri Oct 21, 2011 1:39 am

Re: Authentication problem

Post by Max »

Hi,

I'll look into this to see if we had a regression.

Regards,
- Max

User avatar
Max
Posts: 141
Joined: Fri Oct 21, 2011 1:39 am

Re: Authentication problem

Post by Max »

Found the regression.

The fix will be in the next version.

nserver1
Posts: 2
Joined: Mon Jun 27, 2016 1:35 am

Re: Authentication problem

Post by nserver1 »

Thank you Max!

Your assistance is appreciated!

Post Reply